Unable to change the installation path by passing it as a parameter during unattended mode installation

Comments

4 comments

  • Avatar
    michiel

    Can you tell me the way you are passing it? Could you try the following?


    ./installer.run --installdir /home/paul/installer

     

    0
    Comment actions Permalink
  • Avatar
    Paul Clinton

    Hi Michiel,

    I'm passing it the same way that you have asked me to try. But, no luck with it. It is always taking the default path.

    0
    Comment actions Permalink
  • Avatar
    michiel

    Hi Paul,

    I've tested your example with a simple setup, and I couldn't reproduce it. Can you check it by adding the following snippet to your project?

     <preInstallationActionList>
     <showInfo>
      <text>${installdir}</text>
     </showInfo>
    </preInstallationActionList>

    And share the complete command you are using and the output?

    0
    Comment actions Permalink
  • Avatar
    Paul Clinton

    Hi Michiel,

    Thank you for the reply, you just pointed me in the right direction. Actually in my preInstallationActionList script there were some scripts which were rewriting the installdir parameter. So, due to this I  was facing the issue.

    0
    Comment actions Permalink

Please sign in to leave a comment.