Uninstaller deletes both new file as well as the backup file and so breaks the isntallation

Comments

6 comments

  • Avatar
    BitRock support

    Hi,

    It seems the antivirus program is causing the uninstaller to not be executed properly, giving it a false positive. Can you upload the uninstaller to Virustotal and check for any issues?

    https://www.virustotal.com/gui/home

    Regards,

    Michiel

    0
    Comment actions Permalink
  • Avatar
    Vladimir Holubec

    Dear Michael, 

    I´ve tested the installation file with VirusTotal and I get 0 detection from 72. So from there it seems fine.

    Regards,

    Vladimir

    0
    Comment actions Permalink
  • Avatar
    BitRock support

    Hi Vladimir, 

    Which uninstaller actions are you running? Could you share the snippets with us for the relevant actions?

    Regards,

    Michiel

    0
    Comment actions Permalink
  • Avatar
    Vladimir Holubec

    Dear Michiel,

    I don´t know what exactly do you mean. 

    I am sendind the part of settings in XML file, I hope this is it:

     

    <postUninstallationActionList>
            <copyFile>
                <destination>${installdir}\Server\framework\webapps\arcgis#manager\js\esri\nls\arcgismanager_cs.js</destination>
                <origin>${installdir}\Server\framework\webapps\arcgis#manager\js\esri\nls\arcgismanager_cs.js.bak0</origin>
            </copyFile>
            <deleteFile>
                <path>${installdir}\Server\framework\webapps\arcgis#manager\js\esri\nls\arcgismanager_cs.js.bak0</path>
            </deleteFile></postUninstallationActionList>
     
    Hope this helps. 
     
    Regards,
     
    Vladimir
    0
    Comment actions Permalink
  • Avatar
    BitRock support

    Hi,

    To further investigate this issue, could you create a ticket in the new customer portal? The following guide shows how:

    https://installbuilder.com/how-to-create-ticket.html

    Regards,

    Michiel

     

    0
    Comment actions Permalink
  • Avatar
    Vladimir Holubec

    Dear michiel, BitRock support,

    we don´t have any account there yet. Also I don´t know if we have any support here, becasue as far as I get an information from my colelague, the BitRock version we have is 7.2.2.

    Regards,

    Vladimir

    0
    Comment actions Permalink

Please sign in to leave a comment.