Avoid RegistrySet inside of Wow6432Node

Comments

2 comments

  • Avatar
    juanjo

    You can force the key to be written to the 64bit view using the <wowMode> setting:

      <!-- The 64bit version takes precedence so we check it in second place -->
          <registryGet>
            <key>HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\CurrentVersion</key>
            <name>CurrentVersion</name>
            <variable>currentVersion</variable>
            <wowMode>64</wowMode>
          </registryGet>
    

    You can also force all your installer to write to the 64bit view enabling the 64bit mode as explained in this article.

  • Avatar
    Andre

    Thanks a lot. I now see that the edition panel has the "Wow mode" field, I did not notice since it needs "Advanced mode" which is the default only if Wow mode is filled.

    I'm now going to check if this setting is omitted in WinXP when I have coded:

    <wowmode>64</wowmode> <rulelist> <platformtest type="windows-x64"/> </rulelist>

    or at least that it doesn't cause an error message.

Please sign in to leave a comment.