addscheduledtask not scheduling a task

Comments

1 comment

  • Avatar
    wojciechka

    Unfortunately this is how Windows scheduler works and specifying the username requires specifying a password. Please note that when scheduling tasks to be run as certain user from scheduler GUI, specifying password is also required.

    You may consider adding the program to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run registry to have it run at startup. For example:

    <postInstallationActionList> <registrySet> <key>HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run</key> <name>${project.shortName}</name> <type>REG_SZ</type> <value>"${installdir}/myapp.exe"</value> </registrySet> </postInstallationActionList>

Please sign in to leave a comment.