Desktop shortcut not installing on WIndows

Answered

Comments

2 comments

  • Avatar
    wojciechka

    You should use <desktopShortcut> inside <desktopShortcutList> to create a desktop shortcut. For example:

    <desktopShortcutList>
      <shortcut>
        <comment>${project.fullName}</comment>
        <exec>${installdir}/bin/application</exec>
        <icon>${installdir}/bin/logo.png</icon>
        <name>${project.fullName}</name>
        <windowsExec>${installdir}/bin/application.exe</windowsExec>
      </shortcut>
    </desktopShortcutList>
    

    This will create shortcut to bin/application on Unix systems and bin/application.exe on Windows.

  • Avatar
    Starbuck

    On 64-bit Windows XP if you go into Control Panel and Remove a program it also removes the "..\All Users\Desktop" folder if the program's shortcuts are the only shortcuts in that folder. When re-installing the program if the "..\All Users\Desktop" folder doesn't exist the Desktop icons will not be installed (i.e. when using the Wise Installer and perhaps other older installers).

    On 64-bit Windows Vista and Windows 7 the "C:\Documents and Settings\All Users" folder no-longer exists. The new folder name is "C:\Users\Public", and therefore once again the Wise Installer and perhaps other old installers are not installing the Desktop shortcuts where they're supposed to be located.

    Please address your Thank You notes to Bill Gates at Microsoft Corporation.

Please sign in to leave a comment.