Problem signing executable on a linux machine

Comments

4 comments

  • Avatar
    wojciechka

    Unfortunately we do not have experience in the signcode tool from Mono.

    As for file structure, InstallBuilder appends its payload after the binary part, which is a common practice, but may cause what causes the issue with the signcode tool.

    Please contact us at support@bitrock.com and provide exact InstallBuilder version, command line to sign used to sign and output of:

    tail --bytes=131072 Installer.exe | hd

    Before the signing process.

  • Avatar
    Elvar Þór Ólafsson

    Hi

    I tried running the tail command but I get an error on the hd part. Can you tell me what this hd tool is?

    With regards, Elvar

  • Avatar
    juanjo

    You can replace "hd" with "hexdump". In any case, have you tried using "osslsigncode" to do the signing? Thats should work on Linux.

  • Avatar
    Elvar Þór Ólafsson

    Yeah I also tried this with osslsigncode:

    osslsigncode -spc authenticode.spc -key certificate.key -t http://timestamp.verisign.com/scripts/timstamp.dll -in Installer.exe -out InstallerSigned.exe

    Corrupt PE file - current signature not at end of file: Installer.exe

    Failed

    osslsigncode seems to check whether some certificate structure is in place on the file before trying to sign it.

    With regards, Elvar

Please sign in to leave a comment.